Boost Mobile Community
Got a Question? Search Current Forums
cancel
Showing results for 
Search instead for 
Did you mean: 

MY Boost MOBILE APP - "SOMETHING HAS GONE WRONG" ON IPHONES BUT WORKS ON ANDROID

MY Boost MOBILE APP - "SOMETHING HAS GONE WRONG" ON IPHONES BUT WORKS ON ANDROID

Mendo
Amateur (LVL:1)

MY Boost MOBILE APP - "SOMETHING HAS GONE WRONG" ON IPHONES BUT WORKS ON ANDROID

The "My Boost Mobile" app worked shortly on my son's iphone 7 (IOS 14.4.1) using my Prepaid SIM  but can no longer view data on the Balance screeen.

Upon logging in with the Boost ID (associated with the service) it always says "Something has gone wrong. We're having trouble showinig your data.....Refresh now". Refreshing does nothing.

Note: I can still view usage history and other details in the app so Boost Id seems OK.

 

Have tried with and without Sim card and same result in this iphone.

Have deleted app, restarted and reinstalled but no change.

Tried the same on a iphone X (same IOS version) with his backup and same apple Id, after deleting the app, restarting and reinstalling the app, but exactly same problem.

 

I have downloaded the android app on my Samsung and works fine with the same boost id. Actually problem may have started on the iphone after installing on the Samsung but this could just be a coincidence. Have logged out of the app on Samsung too but same issue remains on the iphone(s).

 

The fact the same issue happens on another iphone using the same apple id, led me to believe that maybe some corrupt setting/data got pushed to icloud. However, the app is not even included is the list of apps backed up to icloud.

 

Any thoughts/help welcomed.