Boost Mobile Community
Got a Question? Search Current Forums
cancel
Showing results for 
Search instead for 
Did you mean: 

'No sim' error after recharge

'No sim' error after recharge

SOLVED
Rookie (LVL:3)

'No sim' error after recharge

Yesterday I recharged my boost sim and now have a 'no sim' message on phone - can still access Internet via wireless but no phone reception! Therefore can't confirm recharge...
Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Rookie (LVL:3)

Re: 'No sim' error after recharge

Yes the sim was fine until yesterday... and I tried a million times turning on/off and reinserting sim! Just plugged it in to charge and did the same thing again and all good! Not sure what changed but... never mind! Thanks for your help...

2 REPLIES 2
Community Founder

Re: 'No sim' error after recharge

No sim normally means there is something physically not right. Suggest turning off the phone, and taking the sim out and back in (make sure it it seated correctly). Then start it up again and see how that goes. You were using that sim in that phone before yesterday without issues, right?

 


This community forum is for Boost Australia queries only. I am a Boost customer, and my comments are purely voluntary. For Boost Support please contact PH 1258881 or https://livechat.boost.com.au/

Rookie (LVL:3)

Re: 'No sim' error after recharge

Yes the sim was fine until yesterday... and I tried a million times turning on/off and reinserting sim! Just plugged it in to charge and did the same thing again and all good! Not sure what changed but... never mind! Thanks for your help...